package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<project>\w+)-(?<core>\d+\.x)-(?<major>\d+)\.(?<patch>[\dx]+)[-\.]?(?<extra>[^\.]+)?\.(tar\.gz|tgz)$
`)
var str = `pkgdeploy-7.x-1.2.1.tar.gz
styles-7.x-2.x-dev.tar.gz
esi-7.x-3.0-alpha1+11-dev.tar.gz
views-7.x-2.1.tar.gz
views_ui-7.x-2.1.tar.gz
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}