using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<project>\w+)-(?<core>\d+\.x)-(?<major>\d+)\.(?<patch>[\dx]+)[-\.]?(?<extra>[^\.]+)?\.(tar\.gz|tgz)$
";
string input = @"pkgdeploy-7.x-1.2.1.tar.gz
styles-7.x-2.x-dev.tar.gz
esi-7.x-3.0-alpha1+11-dev.tar.gz
views-7.x-2.1.tar.gz
views_ui-7.x-2.1.tar.gz
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}