#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<project>\w+)-(?<core>\d+\.x)-(?<major>\d+)\.(?<patch>[\dx]+)[-\.]?(?<extra>[^\.]+)?\.(tar\.gz|tgz)$" & @CRLF & _
""
Local $sString = "pkgdeploy-7.x-1.2.1.tar.gz" & @CRLF & _
"styles-7.x-2.x-dev.tar.gz" & @CRLF & _
"esi-7.x-3.0-alpha1+11-dev.tar.gz" & @CRLF & _
"views-7.x-2.1.tar.gz" & @CRLF & _
"views_ui-7.x-2.1.tar.gz" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")