$re = '/(?:id="ImportGridView"Index: )(.)(?:Name:)/';
$str = 'AgCocoaBridgeView id="ImportGridView"Index: 1Name: 1SingleImport.CR2{15,223,193,253} = Index: 1Name: 1SingleImport.CR2 = Index: 1Name: 1SingleImport.CR2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);