package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:id="ImportGridView"Index: )(.)(?:Name:)`)
var str = `AgCocoaBridgeView id="ImportGridView"Index: 1Name: 1SingleImport.CR2{15,223,193,253} = Index: 1Name: 1SingleImport.CR2 = Index: 1Name: 1SingleImport.CR2`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}