using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:id=""ImportGridView""Index: )(.)(?:Name:)";
string input = @"AgCocoaBridgeView id=""ImportGridView""Index: 1Name: 1SingleImport.CR2{15,223,193,253} = Index: 1Name: 1SingleImport.CR2 = Index: 1Name: 1SingleImport.CR2";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}