const regex = /(?:id="ImportGridView"Index: )(.)(?:Name:)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:id="ImportGridView"Index: )(.)(?:Name:)', '')
const str = `AgCocoaBridgeView id="ImportGridView"Index: 1Name: 1SingleImport.CR2{15,223,193,253} = Index: 1Name: 1SingleImport.CR2 = Index: 1Name: 1SingleImport.CR2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}