re = /\?version=((\d+)\.(\d+)\.(\d+)\.(\d+))$/i
str = 'ClientBin/WebShop.xap?version=0.0.0.53'
# Print the match result
str.match(re) do |match|
puts match.to_s
end