package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\?version=((\d+)\.(\d+)\.(\d+)\.(\d+))$`)
var str = `ClientBin/WebShop.xap?version=0.0.0.53`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}