$re = '/\?version=((\d+)\.(\d+)\.(\d+)\.(\d+))$/i';
$str = 'ClientBin/WebShop.xap?version=0.0.0.53';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);