const regex = /\?version=((\d+)\.(\d+)\.(\d+)\.(\d+))$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\?version=((\\d+)\\.(\\d+)\\.(\\d+)\\.(\\d+))$', 'i')
const str = `ClientBin/WebShop.xap?version=0.0.0.53`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}