re = /var .*?Scope.*?=[\s\S]*?{([\s\S]*?)};[\s\S]*?var .*?Directive.*?=[\s\S]*?{([\s\S]*?)};[\s\S]*?encModule.directive\(['"](.*?)['"][\s\S]*/
str = '//------------------------------------------------------------------
// PrivacyAgreementDialogDirective.js
// Copyright 2013 AppliedMinds, Inc.
//------------------------------------------------------------------
"use strict";
//------------------------------------------------------------------
// Map of attributes to be copied into the scope.
var privacyAgreementDialogScope =
{
};
//------------------------------------------------------------------
// Configuration of the privacyAgreementDialog directive.
var privacyAgreementDialogDirective =
{
\'restrict\' : \'E\',
\'transclude\' : true,
\'scope\' : privacyAgreementDialogScope,
\'controller\' : \'PrivacyAgreementDialogCtrl\',
\'templateUrl\' : \'encirca/common/privacyAgreementDialog/PrivacyAgreementDialog.html\',
\'replace\' : true
};
//------------------------------------------------------------------
// Create the directive.
encModule.directive(\'privacyAgreementDialog\',
enc.func.returns(privacyAgreementDialogDirective));
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end