using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"var .*?Scope.*?=[\s\S]*?{([\s\S]*?)};[\s\S]*?var .*?Directive.*?=[\s\S]*?{([\s\S]*?)};[\s\S]*?encModule.directive\(['""](.*?)['""][\s\S]*";
string input = @"//------------------------------------------------------------------
// PrivacyAgreementDialogDirective.js
// Copyright 2013 AppliedMinds, Inc.
//------------------------------------------------------------------
""use strict"";
//------------------------------------------------------------------
// Map of attributes to be copied into the scope.
var privacyAgreementDialogScope =
{
};
//------------------------------------------------------------------
// Configuration of the privacyAgreementDialog directive.
var privacyAgreementDialogDirective =
{
'restrict' : 'E',
'transclude' : true,
'scope' : privacyAgreementDialogScope,
'controller' : 'PrivacyAgreementDialogCtrl',
'templateUrl' : 'encirca/common/privacyAgreementDialog/PrivacyAgreementDialog.html',
'replace' : true
};
//------------------------------------------------------------------
// Create the directive.
encModule.directive('privacyAgreementDialog',
enc.func.returns(privacyAgreementDialogDirective));
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}