const regex = /var .*?Scope.*?=[\s\S]*?{([\s\S]*?)};[\s\S]*?var .*?Directive.*?=[\s\S]*?{([\s\S]*?)};[\s\S]*?encModule.directive\(['"](.*?)['"][\s\S]*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('var .*?Scope.*?=[\\s\\S]*?{([\\s\\S]*?)};[\\s\\S]*?var .*?Directive.*?=[\\s\\S]*?{([\\s\\S]*?)};[\\s\\S]*?encModule.directive\\([\'"](.*?)[\'"][\\s\\S]*', '')
const str = `//------------------------------------------------------------------
// PrivacyAgreementDialogDirective.js
// Copyright 2013 AppliedMinds, Inc.
//------------------------------------------------------------------
"use strict";
//------------------------------------------------------------------
// Map of attributes to be copied into the scope.
var privacyAgreementDialogScope =
{
};
//------------------------------------------------------------------
// Configuration of the privacyAgreementDialog directive.
var privacyAgreementDialogDirective =
{
'restrict' : 'E',
'transclude' : true,
'scope' : privacyAgreementDialogScope,
'controller' : 'PrivacyAgreementDialogCtrl',
'templateUrl' : 'encirca/common/privacyAgreementDialog/PrivacyAgreementDialog.html',
'replace' : true
};
//------------------------------------------------------------------
// Create the directive.
encModule.directive('privacyAgreementDialog',
enc.func.returns(privacyAgreementDialogDirective));
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}