use strict;
my $str = '//------------------------------------------------------------------
// PrivacyAgreementDialogDirective.js
// Copyright 2013 AppliedMinds, Inc.
//------------------------------------------------------------------
"use strict";
//------------------------------------------------------------------
// Map of attributes to be copied into the scope.
var privacyAgreementDialogScope =
{
};
//------------------------------------------------------------------
// Configuration of the privacyAgreementDialog directive.
var privacyAgreementDialogDirective =
{
\'restrict\' : \'E\',
\'transclude\' : true,
\'scope\' : privacyAgreementDialogScope,
\'controller\' : \'PrivacyAgreementDialogCtrl\',
\'templateUrl\' : \'encirca/common/privacyAgreementDialog/PrivacyAgreementDialog.html\',
\'replace\' : true
};
//------------------------------------------------------------------
// Create the directive.
encModule.directive(\'privacyAgreementDialog\',
enc.func.returns(privacyAgreementDialogDirective));
';
my $regex = qr/var .*?Scope.*?=[\s\S]*?{([\s\S]*?)};[\s\S]*?var .*?Directive.*?=[\s\S]*?{([\s\S]*?)};[\s\S]*?encModule.directive\(['"](.*?)['"][\s\S]*/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}