// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mix)(январь|февраль|март|апрель|май|июнь|июль|август|сентябрь|октябрь|ноябрь|декабрь|january|february|march|april|may|june|july|august|september|october|november|december)\s*(\d+)\s*([\—\-]?)\s*(?:(январь|февраль|март|апрель|май|июнь|июль|август|сентябрь|октябрь|ноябрь|декабрь|january|february|march|april|may|june|july|august|september|october|november|december)\s*(\d+)|(настоящее\s*время)|(till\s*now))
[\s\S]*?
(?:
\s*
(
\d+\s*(?:года?|лет|years?)
|
(?:\d+\s*(?:месяц(?:ев|а)?|months?))
)
)?
(?:
\s*
(
\d+\s*(?:года?|лет|years?)
|
(?:\d+\s*(?:месяц(?:ев|а)?|months?))
)
)").unwrap();
let string = "Февраль 2012—Сентябрь 2014
Zenho Farma Ltd
Резюме обновлено 27 марта 2020 в 15:04
2 года 8 месяцев
Генеральный директор
Эксклюзивный дистрибьютор компании Common Sense (Israel) натерриторииАзербайджана,Грузии,Армении, Узбекистана,Казахстана.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}