import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(январь|февраль|март|апрель|май|июнь|июль|август|сентябрь|октябрь|ноябрь|декабрь|january|february|march|april|may|june|july|august|september|october|november|december)\\s*(\\d+)\\s*([\\—\\-]?)\\s*(?:(январь|февраль|март|апрель|май|июнь|июль|август|сентябрь|октябрь|ноябрь|декабрь|january|february|march|april|may|june|july|august|september|october|november|december)\\s*(\\d+)|(настоящее\\s*время)|(till\\s*now))\n"
+ "[\\s\\S]*?\n"
+ "(?:\n"
+ " \\s*\n"
+ " (\n"
+ " \\d+\\s*(?:года?|лет|years?)\n"
+ " |\n"
+ " (?:\\d+\\s*(?:месяц(?:ев|а)?|months?))\n"
+ " )\n"
+ ")?\n"
+ "(?:\n"
+ " \\s*\n"
+ " (\n"
+ " \\d+\\s*(?:года?|лет|years?)\n"
+ " |\n"
+ " (?:\\d+\\s*(?:месяц(?:ев|а)?|months?))\n"
+ " )\n"
+ ")";
final String string = "Февраль 2012—Сентябрь 2014\n"
+ "Zenho Farma Ltd\n"
+ "Резюме обновлено 27 марта 2020 в 15:04\n"
+ "2 года 8 месяцев\n"
+ "Генеральный директор\n"
+ "Эксклюзивный дистрибьютор компании Common Sense (Israel) натерриторииАзербайджана,Грузии,Армении, Узбекистана,Казахстана.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}