#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mix)(январь|февраль|март|апрель|май|июнь|июль|август|сентябрь|октябрь|ноябрь|декабрь|january|february|march|april|may|june|july|august|september|october|november|december)\s*(\d+)\s*([\—\-]?)\s*(?:(январь|февраль|март|апрель|май|июнь|июль|август|сентябрь|октябрь|ноябрь|декабрь|january|february|march|april|may|june|july|august|september|october|november|december)\s*(\d+)|(настоящее\s*время)|(till\s*now))" & @CRLF & _
"[\s\S]*?" & @CRLF & _
"(?:" & @CRLF & _
" \s*" & @CRLF & _
" (" & @CRLF & _
" \d+\s*(?:года?|лет|years?)" & @CRLF & _
" |" & @CRLF & _
" (?:\d+\s*(?:месяц(?:ев|а)?|months?))" & @CRLF & _
" )" & @CRLF & _
")?" & @CRLF & _
"(?:" & @CRLF & _
" \s*" & @CRLF & _
" (" & @CRLF & _
" \d+\s*(?:года?|лет|years?)" & @CRLF & _
" |" & @CRLF & _
" (?:\d+\s*(?:месяц(?:ев|а)?|months?))" & @CRLF & _
" )" & @CRLF & _
")"
Local $sString = "Февраль 2012—Сентябрь 2014" & @CRLF & _
"Zenho Farma Ltd" & @CRLF & _
"Резюме обновлено 27 марта 2020 в 15:04" & @CRLF & _
"2 года 8 месяцев" & @CRLF & _
"Генеральный директор" & @CRLF & _
"Эксклюзивный дистрибьютор компании Common Sense (Israel) натерриторииАзербайджана,Грузии,Армении, Узбекистана,Казахстана."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")