re = /(январь|февраль|март|апрель|май|июнь|июль|август|сентябрь|октябрь|ноябрь|декабрь|january|february|march|april|may|june|july|august|september|october|november|december)\s*(\d+)\s*([\—\-]?)\s*(?:(январь|февраль|март|апрель|май|июнь|июль|август|сентябрь|октябрь|ноябрь|декабрь|january|february|march|april|may|june|july|august|september|october|november|december)\s*(\d+)|(настоящее\s*время)|(till\s*now))
[\s\S]*?
(?:
\s*
(
\d+\s*(?:года?|лет|years?)
|
(?:\d+\s*(?:месяц(?:ев|а)?|months?))
)
)?
(?:
\s*
(
\d+\s*(?:года?|лет|years?)
|
(?:\d+\s*(?:месяц(?:ев|а)?|months?))
)
)/mix
str = 'Февраль 2012—Сентябрь 2014
Zenho Farma Ltd
Резюме обновлено 27 марта 2020 в 15:04
2 года 8 месяцев
Генеральный директор
Эксклюзивный дистрибьютор компании Common Sense (Israel) натерриторииАзербайджана,Грузии,Армении, Узбекистана,Казахстана.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end