re = /(\d{4})(\d{2})(\d{3})(\d{4})/
str = '2520991515701'
subst = '\\1-\\2-\\3-\\4'
result = str.sub(re, subst)
# Print the result of the substitution
puts result