use strict;
my $str = '2520991515701';
my $regex = qr/(\d{4})(\d{2})(\d{3})(\d{4})/p;
my $subst = '\\1-\\2-\\3-\\4';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";