# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{4})(\d{2})(\d{3})(\d{4})/\1-\2-\3-\4/;t' <<< "2520991515701"