#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d{4})(\d{2})(\d{3})(\d{4})"
Local $sString = "2520991515701"
Local $sSubst = "\1-\2-\3-\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)