import Foundation
let pattern = #"^\s*(add|and|nor|or|sub)\s*(\$[a-z0-9]{2,4}),\s*(\$[a-z0-9]{2,4}),\s*(\$[a-z0-9]{2,4})\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
add $t3,$s3,$s5
add $t3,$s3,$s5
add $v0,$t0,$t0
add $v0,$t0,$t0
and $t2,$t3,$t4
and $t2,$t3,$t4
nor $s0,$s5,$s2
nor $s0,$s5,$s2
or $s0,$s0,$s1
or $s0,$s0,$s1
or $s0,$s2,$s5
or $s0,$s2,$s5
sub $s3,$t0,$t1
sub $s3,$t0,$t1
sub $t0,$zero,$t1
sub $t0,$zero,$t1
sub $t1,$t4,$t8
sub $t1,$t4,$t8
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)