import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(add|and|nor|or|sub)\\s*(\\$[a-z0-9]{2,4}),\\s*(\\$[a-z0-9]{2,4}),\\s*(\\$[a-z0-9]{2,4})\\s*$";
final String string = "add $t3,$s3,$s5\n"
+ "add $t3,$s3,$s5\n"
+ "add $v0,$t0,$t0\n"
+ "add $v0,$t0,$t0\n"
+ "and $t2,$t3,$t4\n"
+ "and $t2,$t3,$t4\n"
+ "nor $s0,$s5,$s2\n"
+ "nor $s0,$s5,$s2\n"
+ "or $s0,$s0,$s1\n"
+ "or $s0,$s0,$s1\n"
+ "or $s0,$s2,$s5\n"
+ "or $s0,$s2,$s5\n"
+ "sub $s3,$t0,$t1\n"
+ "sub $s3,$t0,$t1\n"
+ "sub $t0,$zero,$t1\n"
+ "sub $t0,$zero,$t1\n"
+ "sub $t1,$t4,$t8\n"
+ "sub $t1,$t4,$t8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}