re = /^\s*(add|and|nor|or|sub)\s*(\$[a-z0-9]{2,4}),\s*(\$[a-z0-9]{2,4}),\s*(\$[a-z0-9]{2,4})\s*$/m
str = 'add $t3,$s3,$s5
add $t3,$s3,$s5
add $v0,$t0,$t0
add $v0,$t0,$t0
and $t2,$t3,$t4
and $t2,$t3,$t4
nor $s0,$s5,$s2
nor $s0,$s5,$s2
or $s0,$s0,$s1
or $s0,$s0,$s1
or $s0,$s2,$s5
or $s0,$s2,$s5
sub $s3,$t0,$t1
sub $s3,$t0,$t1
sub $t0,$zero,$t1
sub $t0,$zero,$t1
sub $t1,$t4,$t8
sub $t1,$t4,$t8'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end