#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*(add|and|nor|or|sub)\s*(\$[a-z0-9]{2,4}),\s*(\$[a-z0-9]{2,4}),\s*(\$[a-z0-9]{2,4})\s*$"
Local $sString = "add $t3,$s3,$s5" & @CRLF & _
"add $t3,$s3,$s5" & @CRLF & _
"add $v0,$t0,$t0" & @CRLF & _
"add $v0,$t0,$t0" & @CRLF & _
"and $t2,$t3,$t4" & @CRLF & _
"and $t2,$t3,$t4" & @CRLF & _
"nor $s0,$s5,$s2" & @CRLF & _
"nor $s0,$s5,$s2" & @CRLF & _
"or $s0,$s0,$s1" & @CRLF & _
"or $s0,$s0,$s1" & @CRLF & _
"or $s0,$s2,$s5" & @CRLF & _
"or $s0,$s2,$s5" & @CRLF & _
"sub $s3,$t0,$t1" & @CRLF & _
"sub $s3,$t0,$t1" & @CRLF & _
"sub $t0,$zero,$t1" & @CRLF & _
"sub $t0,$zero,$t1" & @CRLF & _
"sub $t1,$t4,$t8" & @CRLF & _
"sub $t1,$t4,$t8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")