re = /^([A-Za-z]+)(\s*)([0,1]*[0-9])(,*\s*)([0-9]{2,4})$/m
str = 'January 15, 2018
January 15,2018
January15, 2018
January15,2018
January 15 2018
Feb 15, 2018
Feb15, 18'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end