package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Za-z]+)(\s*)([0,1]*[0-9])(,*\s*)([0-9]{2,4})$`)
var str = `January 15, 2018
January 15,2018
January15, 2018
January15,2018
January 15 2018
Feb 15, 2018
Feb15, 18`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}