const regex = /^([A-Za-z]+)(\s*)([0,1]*[0-9])(,*\s*)([0-9]{2,4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Za-z]+)(\\s*)([0,1]*[0-9])(,*\\s*)([0-9]{2,4})$', 'gm')
const str = `January 15, 2018
January 15,2018
January15, 2018
January15,2018
January 15 2018
Feb 15, 2018
Feb15, 18`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}