#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Za-z]+)(\s*)([0,1]*[0-9])(,*\s*)([0-9]{2,4})$"
Local $sString = "January 15, 2018" & @CRLF & _
"" & @CRLF & _
"January 15,2018" & @CRLF & _
"" & @CRLF & _
"January15, 2018" & @CRLF & _
"" & @CRLF & _
"January15,2018" & @CRLF & _
"" & @CRLF & _
"January 15 2018" & @CRLF & _
"" & @CRLF & _
"Feb 15, 2018" & @CRLF & _
"" & @CRLF & _
"Feb15, 18"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")