// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<opening>\<\w)|(?<closing>\<?\/\w*\>)").unwrap();
let string = "<div Id='topDiv' Class='randomClass'><p Id='topP' Class='randomParagraph'></p>Blah<span></span>lkj<div Id='blahyay' ><div></div></div></div><div />";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}