using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<opening>\<\w)|(?<closing>\<?\/\w*\>)";
string input = @"<div Id='topDiv' Class='randomClass'><p Id='topP' Class='randomParagraph'></p>Blah<span></span>lkj<div Id='blahyay' ><div></div></div></div><div />";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}