const regex = /(?<opening>\<\w)|(?<closing>\<?\/\w*\>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<opening>\\<\\w)|(?<closing>\\<?\\\/\\w*\\>)', 'g')
const str = `<div Id='topDiv' Class='randomClass'><p Id='topP' Class='randomParagraph'></p>Blah<span></span>lkj<div Id='blahyay' ><div></div></div></div><div />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}