package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<opening>\<\w)|(?<closing>\<?\/\w*\>)`)
var str = `<div Id='topDiv' Class='randomClass'><p Id='topP' Class='randomParagraph'></p>Blah<span></span>lkj<div Id='blahyay' ><div></div></div></div><div />`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}