import Foundation
let pattern = #"^P5RNP\d{8}\/\d{5}S\d+\.\d{2}A$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"P5RNP15226660/01981S15851.22A"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}