package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^P5RNP\d{8}\/\d{5}S\d+\.\d{2}A$`)
var str = `P5RNP15226660/01981S15851.22A`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}