using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^P5RNP\d{8}\/\d{5}S\d+\.\d{2}A$";
string input = @"P5RNP15226660/01981S15851.22A";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}