const regex = /^P5RNP\d{8}\/\d{5}S\d+\.\d{2}A$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^P5RNP\\d{8}\\\/\\d{5}S\\d+\\.\\d{2}A$', '')
const str = `P5RNP15226660/01981S15851.22A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}