$re = '/^[a-z]{2}.sporttu.com/';
$str = 'ae.sporttu.com
al.sporttu.com
at.sporttu.com
au.sporttu.com
az.sporttu.com
ba.sporttu.com
badminton.sporttu.com
commonwealthgames.sporttu.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);