#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[a-z]{2}.sporttu.com"
Local $sString = "ae.sporttu.com" & @CRLF & _
"al.sporttu.com" & @CRLF & _
"at.sporttu.com" & @CRLF & _
"au.sporttu.com" & @CRLF & _
"az.sporttu.com" & @CRLF & _
"ba.sporttu.com" & @CRLF & _
"badminton.sporttu.com" & @CRLF & _
"commonwealthgames.sporttu.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")