import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z]{2}.sporttu.com";
final String string = "ae.sporttu.com\n"
+ "al.sporttu.com\n"
+ "at.sporttu.com\n"
+ "au.sporttu.com\n"
+ "az.sporttu.com\n"
+ "ba.sporttu.com\n"
+ "badminton.sporttu.com\n"
+ "commonwealthgames.sporttu.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}