const regex = /^[a-z]{2}.sporttu.com/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z]{2}.sporttu.com', '')
const str = `ae.sporttu.com
al.sporttu.com
at.sporttu.com
au.sporttu.com
az.sporttu.com
ba.sporttu.com
badminton.sporttu.com
commonwealthgames.sporttu.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}