// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^master$|^main$|^release.*").unwrap();
let string = "release
master
main
release-foo
my-release
user/ianjirka/release-foo
user/ianjirka/foo
user/ianjirka/main
user/ianjirka/master
user/ianjirka/release
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}