import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^master$|^main$|^release.*";
final String string = "release\n"
+ "master\n"
+ "main\n"
+ "release-foo\n"
+ "my-release\n"
+ "user/ianjirka/release-foo\n"
+ "user/ianjirka/foo\n"
+ "user/ianjirka/main\n"
+ "user/ianjirka/master\n"
+ "user/ianjirka/release\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}