re = /^master$|^main$|^release.*/m
str = 'release
master
main
release-foo
my-release
user/ianjirka/release-foo
user/ianjirka/foo
user/ianjirka/main
user/ianjirka/master
user/ianjirka/release
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end