using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^master$|^main$|^release.*";
string input = @"release
master
main
release-foo
my-release
user/ianjirka/release-foo
user/ianjirka/foo
user/ianjirka/main
user/ianjirka/master
user/ianjirka/release
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}