// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?P<destination>\d+\.\d+\.\d+\.\d+)\ +(?P<gateway>\d+\.\d+\.\d+\.\d+)\ +(?P<mask>\d+\.\d+\.\d+\.\d+)\ +\w+\ +\d+\ +\d+\ +\d+\ +(?P<interface>\w+)").unwrap();
let string = "Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
0.0.0.0 192.168.100.254 0.0.0.0 UG 100 0 0 enp2s0
10.8.0.1 10.8.0.109 255.255.255.255 UGH 0 0 0 tun0
10.8.0.109 0.0.0.0 255.255.255.255 UH 0 0 0 tun0
192.168.10.0 10.8.0.109 255.255.255.0 UG 0 0 0 tun0
192.168.100.0 0.0.0.0 255.255.255.0 U 100 0 0 enp2s0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}