import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<destination>\\d+\\.\\d+\\.\\d+\\.\\d+)\\ +(?P<gateway>\\d+\\.\\d+\\.\\d+\\.\\d+)\\ +(?P<mask>\\d+\\.\\d+\\.\\d+\\.\\d+)\\ +\\w+\\ +\\d+\\ +\\d+\\ +\\d+\\ +(?P<interface>\\w+)";
final String string = "Table de routage IP du noyau\n"
+ "Destination Passerelle Genmask Indic Metric Ref Use Iface\n"
+ "0.0.0.0 192.168.100.254 0.0.0.0 UG 100 0 0 enp2s0\n"
+ "10.8.0.1 10.8.0.109 255.255.255.255 UGH 0 0 0 tun0\n"
+ "10.8.0.109 0.0.0.0 255.255.255.255 UH 0 0 0 tun0\n"
+ "192.168.10.0 10.8.0.109 255.255.255.0 UG 0 0 0 tun0\n"
+ "192.168.100.0 0.0.0.0 255.255.255.0 U 100 0 0 enp2s0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}