#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?P<destination>\d+\.\d+\.\d+\.\d+)\ +(?P<gateway>\d+\.\d+\.\d+\.\d+)\ +(?P<mask>\d+\.\d+\.\d+\.\d+)\ +\w+\ +\d+\ +\d+\ +\d+\ +(?P<interface>\w+)"
Local $sString = "Table de routage IP du noyau" & @CRLF & _
"Destination Passerelle Genmask Indic Metric Ref Use Iface" & @CRLF & _
"0.0.0.0 192.168.100.254 0.0.0.0 UG 100 0 0 enp2s0" & @CRLF & _
"10.8.0.1 10.8.0.109 255.255.255.255 UGH 0 0 0 tun0" & @CRLF & _
"10.8.0.109 0.0.0.0 255.255.255.255 UH 0 0 0 tun0" & @CRLF & _
"192.168.10.0 10.8.0.109 255.255.255.0 UG 0 0 0 tun0" & @CRLF & _
"192.168.100.0 0.0.0.0 255.255.255.0 U 100 0 0 enp2s0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")